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Studio 5000  

Studio 5000 is an Online & Offline, programming and monitoring 

software for ControlLogix family of Allen Bradley PLCs. These 

include CompactLogix, ControlLogix and GuardLogix PLCs.  

When Rockwell Software updated RSLogix 5000 software from 

version 20 to version 21, the software was renamed Studio 5000.  

(Sometimes referred to as Logix Designer).  

Allen Bradley’s ControlLogix 1756 – L7x series of PLCs are the 

current processors that can use Studio 5000 software. The 1756 –

L7x processors include 1756 – L71, L72, L73, L74, L75. 

Note: RSLogix 5000 software versions 18, 19 and 20 can be used 

          with early releases of 1756-L7x processors, version 18 –  

          L73/75, version 19- L72/73/74/75, version 20 –  

          L71/72/73/74/75 

RSLogix 5000 software is used with 1756-L1, 1756-L5x, 1756-

L6x and some 1756-L7x PLCs (See Note above). 

Start/Running  Studio 5000 

Execute RSLogix5000 from an icon on the desktop, 

 

Figure 1-A  Shortcut Icon – Studio 5000 

Note: Different Shortcut icon for Studio 5000 than for Logix 5000 
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Figure 2-A  Shortcut Icon – Logix 5000 

or by choosing the application from the Rockwell Software folder 

within the Start menu. 

 

Figure 3-A 

RSLinx Classic may need to be updated to work with Studio 5000 

software:   Studio 5000 v21 – RSLinx v3.51.00.10 

                  Studio 5000 v23 – RSLinx v3.61.00 

                  Studio 5000 v24 – RSLinx v3.71.00 

 

Studio 5000 is copy protected with a FactoryTalk Activation.  The 

EVRSI activation files cannot be used the Studio 5000.  
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 If FactoryTalk Activation is missing or cannot be found, Studio 

5000 will not run. 

The start screen for Studio 5000 is shown in Figure 4-A. 

 

Figure 4-A – Start Screen Studio 5000 

From the start screen: 

Create – start a new project 

               Import a project 

               open an included sample file 

 Open – open an existing project 

             upload a project  

             open an included sample file 

Explore – navigate to Help File information 

Recent Projects – lists latest projects that were opened in Studio 

                             5000. 
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To select a Recent Project – Click on the project name. 

The Studio 5000 splash screen opens 

 

See Figure 5-A 

 

Figure 5-A 

Studio 5000 Splash Screen 

 

The selected project opens in the main screen of Studio 5000 
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Figure 6-A – Main Screen 

Note: To view Ladder Logic window – Click on the Routine icon 

Note: The main screen in Studio 5000 is similar to Logix 5000 

          See ControlLogix Lesson6 Intro to RSLogix5000 for 

          Toolbar and Window descriptions 

This Lesson will cover the steps to create a new project in Studio 

5000. 

On the Start Screen - Select New Project in the Create list. 
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Figure 7-A 

Studio 5000 will create an ACD project file. 

NOTE: This is the same file extension used in RSLogix 5000.  

 .ACD –is the extension for the native 5000 project file.  This 

holds all of the project’s, data, instructions, configurations 

and descriptions. This is the project that opens in the Studio 

5000 software and is downloaded to the processor. 

 

Figure 8-A  

 Icon for ACD project file 

 

There are two addition file types that Studio 5000 projects files 
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can use: 

Note: These are projects that are imported into Studio 5000 

           and are used  to create an .ACD project file. 

 .L5K – ASCII text file which is an archived or compressed 

file created by an .ACD file.  When this file is opened with 

Studio 5000, an import will occur which creates the .ACD 

file in the Project Directory, and then Studio 5000 will open 

the .ACD file. Able to view file information in a text editor. 

 

 Figure 9-A  

 Icon for L5K project file 

 

 .L5X – Extensible Markup Language (XML) file. Similar to 

an .L5K file. File can be viewed in a text editor or web 

browser.  

 
Figure 10-A  

 Icon for L5X project file 

After choosing New Project from the Start Screen – the New 

Project window opens.  
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See Figure 11-A. 

Select the type of processor for the project. 

This example will use a ControlLogix 1756-L71. 

 

Figure 11-A 

Name the Project 

Use Lesson1.0 RSLinx to create an on-line connection to PLC. 

Conventions for Names 
Throughout a Studio 5000 project, you define names for the different 

elements of the project, such as the project name, controller, data addresses 

(tags), routines, and I/O modules. As you enter names, follow these rules. 
 

• Only letters, numbers, and underscores (_) 
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• Must start with a letter or an underscore 

• ≤ 40 characters 

• No consecutive or trailing underscores 

• Not case sensitive 

For the example the project name is new_project 

Location: is where the project file will be stored 

                 Use the Browse button to change Location 

                 

 

Figure 12-A 

Click the Next button 

The next screen contains  



 

 

PLC220 Student Lesson 2, 1/23/17 

I AM iSTAR, A DOL funded project 

 
 

Studio 5000 
 

12 

 Processor revision 

 Chassis size 

 Processor slot location 

This information can be viewed from the RSWho screen in 

RSLinx. 

 

Figure 13-A 

Hardware Information for the ControlLogix System 

 

Click the Finish button 
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Studio 5000 will create an .ACD and store it in the Location 

path. 

 

Note: Project Name will also be the name of the processor. 

          This can be changed by saving the project file with a 

          different name.     

 

The Studio 5000 Main Screen opens. 

  

 

Figure 14-A 

Studio 5000 Main Screen 

By default the left-side windows opens with the Controller 

Organizer view, same as RSLogix 5000. 
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In Studio 5000, the left-side widow can be toggled to the Logical 

Organizer view by clicking on the icon shown in Figure 15-A on 

the standard toolbar.  

 

Figure 15-A Logical Organizer icon 

To return to the Controller Organizer window, click the icon to the 

left of the Logical Organizer icon. 

 

Studio 5000 main screen - Logical Organizer window 

 

Figure 16-A 

 

Configure the Studio 5000 main screen to view the Controller 

Organizer window. 
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From the Online toolbar – Click the Controller Properties icon. 

The Controller Properties icon is below the Key Switch icon. 

 

 

Figure 17-A 

Controller Properties icon 

 

 

On the Controller Properties window – navigate to General tab. 

The General tab shows hardware information that was configured 

at the beginning of the project.  

Project information can be view/ modified on the General tab.  
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Figure 18-A 

Type: Processor used for project 

Revision: Revision of project file 

Note: Major revision of project file must match major revision of  

           processor. 

   

Note: Change Type and Revision information using Change 

         Controller button. 

Note: Processor revision information can be found on RSWho  
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          screen in RSLinx. 

Name: Processor Name 

Chassis Type: Chassis Part Number for project 

Slot: Slot location of Processor 

If any changes are made on the Controller Properties window – 

Click Apply or OK button to keep changes. 

 

I/O Configuration 

Using 1756-L7x processors, I/O configuration can be 

accomplished offline or online. With previous types of  

ControlLogix processors (1756-L6x or 1756-L5x) I/O 

configuration is offline only. 

 

Offline I/O Configuration 

Right mouse click on the I/O Configuration folder in the Controller 

Organizer window.  

Select New Module 

 

Figure 19-A 
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On the Select Module Type screen - Click the Show Filters button 

in the upper right corner of the screen.  

 

Figure 20-A 

Select only Digital check box in the Module Type Category Filters 

area of the screen. Catalog Numbers are now only for Digital type 

of I/O modules. 

Select 1756-IB16 – This matches part number of module in slot 2 

of Demo Board.   
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Figure 21-A 

Double Click 1756-IB16 and on the Select Major Revision screen 

select 3 for Major Revision 

 

Figure 22-A 

Note: I/O module part number and revision information can be 

          found on RSWho screen in RSLinx. 

 

Click OK button 

 

Figure 23-A 

On the New Module screen name the module and change slot as 

shown in Figure 24-A. 

Name – Slot2 (use Studio 5000 naming rules – See page 9) 

Slot – is the slot location in the chassis where the module is  
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           located. Slot 2 on Demo Board layout. 

See Figure 24-A 

 

Click the OK button 

 

Figure 24-A 

In the Controller Organizer window – I/O Configuration folder – 

verify [2]1756-IB16 slot2 is in the configuration list. 

[2] – Slot location 

1756-IB16 module part number 

slot2 – module name 
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Figure 25-A 

In the Controller Organizer window – navigate to Controller Tags 

listed under Controller folder. 

See Figure 26-A 

 

Figure 26-A 

Double click – Controller Tags to open tag screen 

Local:2:C and Local:2:I are tag categories for the 1756-IB16 

module. 

 

Figure 27-A 

Local – module located in same chassis as processor 

2 – slot location in chassis 

C – configuration data 

I – Input data 
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To close the tag screen – navigate to the upper right corner of the 

Studio 5000 screen. 

Click the lower x button 

 

Figure 28-A 

Note: upper (Red) x will close the Studio 5000 application 

 

Online I/O Configuration 

 

Figure 29-A 

Click New Module to open Select Module Type screen 
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Figure 30-A 

Click Module Discovery tab 

 

Figure 31-A 

Must be online to use Module Discovery 
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Figure 32-A 

Click Close button 

 

Choose File -> Save to save project file 

 

Figure 33-A 
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Navigate to Path toolbar and click the Who Active button. 

 

Figure 34-A 

From the Who Active screen 

Using AB_ETHIP-1 driver – Select Ethernet module that matches 

the Ethernet address of module in Demo Board. 

Click + sign to left of Ethernet module 

Click + sign to left of Backplane icon 

Click on the processor from module list 

Click Download button on right side of the Who Active screen. 
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Figure 35-A 

Click Download on the bottom of the Download screen 
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Figure 36-A 

Downloading screen shows download status 

 

Figure 37-A 
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If the processor was in RUN mode prior to downloading, the Logix 

Designer screen can put the processor back into RUN by clicking 

the Yes button or to leave the processor in PROGRAM mode click 

No button. 

 

Figure 38-A 

From the Task folder in the Controller Organizer window – drill 

down to MainRoutine. 

Double click MainRoutine to open the ladder logic window. 

There are no instructions in the MainRoutine. 

 

Figure 39-A 
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Right mouse click on the I/O Configuration folder in the Controller 

Organizer window.  

Note: Discover Modules is active when online. 

 

Figure 40-A 

Right click or double click Discover Module to open Select 

Module Type – Module Discovery tab. 

Note: Modules in the chassis not listed in I/O Configuration tab 

          have Create button in action column  
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Figure 41-A 

Note: 1756-IB16 module already listed in I/O Configuration – No  

           action needed. 

An alternate way to navigate to the Module Discovery tab is to 

right click on I/O Configuration in the Controller Organizer 

window. 

Click New Module  

 

Figure 42-A 
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On the Select Module Type screen – Click Module Discovery tab 

 

Figure 43-A 

A list of modules in the chassis is shown in the Select Module 

Type screen. 

See Figure 44-A. 

Note: Figure 44-A is the same screen as Figure 41-A 

 

Figure 44-A - Select Module Type 
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To add a module click the Create button in th Action column. 

For this example the module in Slot 3 will be added online 

Click the Create button for 1756-OB16E 

 

Figure 45-A 

Fill –in Name for module as shown in Figure 46-A 
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Figure 46-A 

Click the OK button 

 

Note: Danger warning when creating module online 

 

Figure 47-A 
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Click OK Button 

If Module Properties Report screen opens 

Click OK to close 

 

Figure 48-A 

 

Module is now in the I/O Configuration folder 

 

Figure 49-A 
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Figure 50-A 

Double click – Controller Tags to open tag screen 

Local:2:C and Local:2:I are tag categories for the 1756-IB16 

module. 

Local:3:C, Local:2:I and Local:2:O are tag categories for the 1756-

OB16E module.  

 

Figure 51-A 

Controller Tags 

To close the tag screen – navigate to the upper right corner of the 

Studio 5000 screen. 

Click the lower x button 

 

Figure 52-A 

Note: upper (Red) x will close the Studio 5000 application 
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Navigate to I/O Configuration tab 

 

 

Right mouse click on the I/O Configuration folder in the Controller 

Organizer window.  

 

Figure 53-A 

Right click or double click Discover Module to open Select 

Module Type – Module Discovery tab. 

Note: 1756-OB16E no longer has Create button since it is now in  

           the I/O Configuration list. 
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Figure 54-A 

Repeat Module Discovery to add additional modules online 

Note: Module can be added manually online by choosing 

           I/O Configuration -> New Modules 

 

Figure 55-A 

The process will follow the steps outlined in Offline I/O 

Configuration page 15. 
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Module can be deleted online as long as none of the modules tags 

are being referenced by processor instructions 

 

Figure 56-A 

In the I/O Configuration folder – Right click module to be deleted 

and click Delete 

Confirm the deletion by clicking Yes 

 

Figure 57-A 

The module is no longer list in the I/O Configuration folder 
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Figure 58-A 

Save Online changes 

From the Menu bar – Select File -> Save As 

 

Figure 59-A 

Click Yes to Save changes made online 

 

Figure 60-A 
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Click the icon on processor mode button 

 Green if processor is in RUN mode 

 Light Blue if processor is in PROGRAM mode 

 Yellow if processor is in TEST mode 

 

Figure 61-A 

Click Go Offline 

Studio 5000 will be taken Offline and the computer is on longer 

monitoring processor. 

The mode button on the Online toolbar indicate Offline 

 

Figure 62-A 
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Adding Ladder Instructions 

From the Task folder navigate to MainRoutine 

 

Figure 63-A 

 

Double click MainRoutine to open Ladder window if it is not 

already opened. 

 

 

Figure 64-A 

 

From the Language Element toolbar -> Favorite tab drag the XIC 

instruction (NO contact symbol) and position it on the left side of 

ladder rung 0.  
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Figure 65-A 

From the Language Element toolbar -> Favorite tab drag the OTE 

instruction - ( ) symbol- and position it on the right side of ladder 

rung 0.  

 

Figure 66-A 

Rung 0 should appear as shown in Figure 67-A 

 

Figure 67-A 

 

To assign tags to the XIC instruction, click the “?” above the 

instruction to place a blue rectangle on the “?”. 
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Figure 68-A 

 

Double click the blue rectangle to open a selection box 

 

 
Figure 69-A 

 

Click the down arrow on the selection box to view Show tag 

window. 

 

Ensure the Show controller tags box is checked. 

Click Local:2:I to select input tags for the module in Slot 2. 

 

 
Figure 70-A 

 

Click the “ +” sign to the left Local:2:I to expand tag selection. 
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Figure 71-A 

 

On the expanded Local:2:I tree – click  Local:2:I.Data 

A down arrow appears to the left of  DINT 

 

 
Figure 72-A 

 

Click the down arrow to the left of DINT to view a number pallet 

0-31. Sometimes call a Bit Picker screen. These numbers 

represents the module terminal connections. 
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Toggle the SS7 switch on the demo board – Note a yellow 7 on the 

input module faceplate when the switch is providing a voltage 

signal to terminal 7 on the module. When the module has no 

voltage on terminal the yellow 7 is off. 

 

Click 7 on the number pallet screen. 

 

 
Figure 73-A 

Press Enter key on computer keyboard. 

 

The tag – Local:2:I.Data.7 – appears above the XIC instruction. 

This represents the SS7 switch on the demo board. 

 

 
Figure 74-A 

Follow the same steps to assign a tag to the OTE instruction 

(output). 

 

Click the “?” above the OTE instruction to place a blue rectangle 

on the “?”. 
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Figure 75-A 

 

Double click the blue rectangle to open a selection box 

 

 
Figure 76-A 

 

Click the down arrow on the selection box to view Show tag 

window. 

 

Ensure the Show controller tags box is checked. 

Click Local:3:O to select output tags for the module in Slot 3 

 

 
Figure 77-A 

 

Note: The output module in slot 3 has a group of tags – Local:3:I 

           and a group of tags – Local:3:O 
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           Tags that control the output devices connected to the  

           module in slot 3 use the Local:3:O group.   

 

Click the “ +” sign to the left Local:3:O to expand tag selection. 

 

On the expanded Local:3:O tree – click  Local:3:O.Data 

A down arrow appears to the left of DINT 

 
Figure 78-A 

 

Click the down arrow to the left of DINT to view a number pallet 

0-31. These numbers represents the module terminal connections. 

 

Click 3 on the number pallet screen. 
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Figure 79-A 

Press Enter key on computer keyboard. 

 

The tag – Local:3:O.Data.3 – appears above the OTE instruction. 

This represents the PL3 indicator on the demo board. 

See Figure 80-A 

 
Figure 80-A 

 

Add Tag Descriptions 

Place mouse pointer on tag Local:2:I.Data.7 

Right click to view the menu show in Figure 81-A. 
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Figure 81-A 

 

Click the Edit Main Operand Description selection to view tag 

Description editor window 

 

 
Figure 82-A 

Type in a tag description of SS7 in the Description editor window 

 

Click the green check mark (Apply modifications) to assign the 

description SS7 to the tag Local:2:I.Data.7. 
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The description SS7 appears above the tag name for the XIC 

instruction. 

 

 
Figure 83-A 

 

Follow the same steps to assign a tag description to the OTE 

instruction tag Local:3:O.Data.3. 

 

Place mouse pointer on tag Local:3:O.Data.3 

Right click to view the menu show in Figure 84-A. 

 

 
Figure 84-A 

 

Click the Edit Main Operand Description selection to view tag 

Description editor window 
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Figure 85-A 

 

Type in a tag description of PL3 in the Description editor window 

 

Click the green check mark (Apply modifications) to assign the 

description PL3 to the tag Local:3:O.Data.3. 

 

The description PL3 appears above the tag name for the XIC 

instruction. 

 
Figure 86-A 

 

From the Menu bar – click File -> Save to save modifications to 

the project file. 

 
Figure 87-A 

Click the Controller Properties button on the Online toolbar. 
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Figure 88-A 

 

On the Controller Properties window – Click the Project tab. 

 

 
Figure 89-A 

 

On the Project screen verify Download Project Documentation and 

Extended Properties check box is checked. 

See Figure 90-A  

 

When the Download Project Documentation and Extended 

Properties check box is checked project, documentation 

(Comments / Descriptions) are downloaded to a 1756-L7x 

processor. 
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With previous ControlLogix processors, 1756-L5x and 1756-L6x, 

and Allen Bradley legacy PLCs – SLC 500 and PLC 5 systems – 

documentation is stored in the offline project file and is not 

downloaded to the processors. 

 

 
Figure 90-A 

Download Project Documentation and Extended Properties 

Check Box 

 

 

Click the OK button to close Controller Properties window. 

 

 
Figure 91-A 
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Download Project to Processor 

Navigate to Path toolbar and click the Who Active button. 

 

Figure 92-A 

From the Who Active screen 

Using AB_ETHIP-1 driver – Select Ethernet module that matches 

the Ethernet address of module in Demo Board. 

Click + sign to left of Ethernet module 

Click + sign to left of Backplane icon 

Click on the processor from module list 

Click Download button on right side of the Who Active screen. 
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Figure 93-A 

Click Download on the bottom of the Download screen 
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Figure 94-A 

Downloading screen shows download status 

 

Figure 95-A 
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If the processor was in RUN mode prior to downloading, the Logix 

Designer screen can put the processor back into RUN by clicking 

the Yes button or to leave the processor in PROGRAM mode click 

No button. 

 

Figure 96-A 

 

View Ladder Logic window 

Toggle SS7 switch on the demo board 

SS7 turned to left - PL3 indicator OFF 

SS7 turned to right – PL3 indicator ON 

 
Figure 97-A 

 

Compare Online toolbar information in Studio 5000 software to 

1756-L71 processor faceplate information. 



 

 

PLC220 Student Lesson 2, 1/23/17 

I AM iSTAR, A DOL funded project 

 
 

Studio 5000 
 

58 

 

The display on the 1756-L7x processor shows the processor name 

if every is correctly configured 

Note; The display will scroll error information if there are 

           processor faults or configuration errors. 

 

When there are no errors or faults processor OK indicator -  solid 

green. 

 

When processor is in RUN mode -  RUN indicator – solid green 

 
Figure 98-A 

1756-L7x Faceplate 

 

When there are no errors or faults processor Controller OK 

indicator - solid green. 

 

When processor is in RUN mode -  RUN Mode indicator – solid 

green 
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Figure 98-A 

Studio 5000 Online Toolbar 
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Review Questions 

1. T F The controller tags will be sent to the PLC 

during a download. 

 

2. The designation in the Controller Organizer window that 

indicates that an object can be expanded out (there are 

sub-objects) is: 

 a)  A “+” sign. 

 b)  A “-“ sign. 

 c)  A folder. 

 d)  An asterisk “*”. 

 

3. The command used to designate the transfer of a program 

from the Project Directory to the PLC. 

 a)  Download 

 b)  Upload 

 c)  Online 

 d)  Verify 

 

4. T F RSLinx must be running in order to go Online to 

a ControlLogix processor with Studio 5000. 
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5. While viewing a project file Online to a processor with 

Studio 5000, what data on the screen is could be from the 

project file on the hard drive? 

 a)  Ladder Logic 

 b)  Data Values 

 c)  Tags 

 d)  None of the above 

 

6. T F When a project file is downloaded to a 

ControlLogix processor, the machine the 

processor is running will be shut down. 

 

7. T F The project file can be downloaded to a PLC,  if 

the PLC is in RUN mode. 

 

8. T F When a project file is uploaded from an 

ControlLogix processor, the machine the 

processor is running will be shut down. 

 

9. T F ControlLogix manuals are included in the Help 
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files. 

 

10. T F Typically a .ACD file will be smaller in size than 

a .L5K file, for a given project. 

11. Valid file types used with Studio 5000 software are 

 a)  .ACD 

 b)  .L5K 

 c)  .L5X 

 d)  .RSS 

 

12. The Controller Properties button is located on which 

toolbar 

 a)  Path 

 b)  Online. 

 c)  Standard 

 d)  Language Element. 
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Review Question Answers: 

1) T

2) a

3) a

4) T

5) d

6) T

7) F

8) F

9) T

10) F

11) a, b, c

12) b
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